Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.9

Bug #11507 update/install fails, cause "Invalid tgz file"
Submitted: 2007-07-03 08:56 UTC
From: phpmyforum Assigned:
Status: Bogus Package: PEAR (version 1.5.4)
PHP Version: 5.2.3 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2007-07-03 08:56 UTC] phpmyforum (Christoph Roeder)
Description: ------------ When I try to upgrade or install pear, I'll get "Invalid tgz file". Btw. the option "--alldeps" doesn't exist for upgrade-all Test script: --------------- $ pear upgrade-all Expected result: ---------------- Upgrade of PEAR and Console_Getopt Actual result: -------------- $ pear upgrade-all Will upgrade channel://pear.php.net/console_getopt Will upgrade channel://pear.php.net/pear Did not download optional dependencies: pear/XML_RPC, use --alldeps to download automatically pear/PEAR can optionally use package "pear/XML_RPC" (version >= 1.4.0) downloading Console_Getopt-1.2.3.tgz ... Starting to download Console_Getopt-1.2.3.tgz (4,011 bytes) ....done: 4,011 bytes Could not get contents of package "/tmp/pear/cache/Console_Getopt-1.2.3.tgz". Invalid tgz file. Download of "pear/console_getopt" succeeded, but it is not a valid package archive Error: cannot download "pear/Console_Getopt" downloading PEAR-1.6.1.tgz ... Starting to download PEAR-1.6.1.tgz (295,780 bytes) ...done: 295,780 bytes Could not get contents of package "/tmp/pear/cache/PEAR-1.6.1.tgz". Invalid tgz file. Download of "pear/pear" succeeded, but it is not a valid package archive Error: cannot download "pear/PEAR" Download failed upgrade-all failed

Comments

 [2007-08-18 21:29 UTC] cellog (Greg Beaver)
PEAR version? does /tmp/pear/cache exist? do you have write permissions?
 [2007-08-19 07:41 UTC] phpmyforum (Christoph Roeder)
I'm running th command as root, so yes I have enough permissions ;) The folder and files will also be created: $ l /tmp/pear/cache/ ... -rw-r--r-- 1 root root 151 2007-08-19 09:38 cebfc2db563cacd14abbf18f437cc384rest.cacheid -rw-r--r-- 1 root root 4011 2007-08-19 09:38 Console_Getopt-1.2.3.tgz -rw-r--r-- 1 root root 1712 2007-08-19 09:38 db76a8a03cb04516e14bd1e599d376a7rest.cachefile -rw-r--r-- 1 root root 151 2007-08-19 09:38 db76a8a03cb04516e14bd1e599d376a7rest.cacheid -rw-r--r-- 1 root root 908 2007-08-19 09:38 faea342fd87fdec1d86f522230325d03rest.cachefile -rw-r--r-- 1 root root 151 2007-08-19 09:38 faea342fd87fdec1d86f522230325d03rest.cacheid -rw-r--r-- 1 root root 295780 2007-08-19 09:38 PEAR-1.6.1.tgz
 [2007-08-19 15:00 UTC] cellog (Greg Beaver)
please confirm "pear -V" is version 1.6.1 change download_dir to another location pear config-set download_dir /some/other/path and try again Also, what Archive_Tar version do you have?
 [2007-08-19 19:20 UTC] phpmyforum (Christoph Roeder)
The problem is that I can't upgrade PEAR. ~~~~~~~~~ $ pear -V PEAR Version: 1.5.4 PHP Version: 5.2.3 Zend Engine Version: 2.2.0 Running on: Linux tux 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 $ sudo pear upgrade PEAR Password: Did not download optional dependencies: pear/XML_RPC, use --alldeps to download automatically pear/PEAR can optionally use package "pear/XML_RPC" (version >= 1.4.0) downloading PEAR-1.6.1.tgz ... Starting to download PEAR-1.6.1.tgz (295,780 bytes) .............................................................done: 295,780 bytes Could not get contents of package "/tmp/pear/cache/PEAR-1.6.1.tgz". Invalid tgz file. Download of "pear/PEAR" succeeded, but it is not a valid package archive Error: cannot download "pear/PEAR" downloading Console_Getopt-1.2.3.tgz ... Starting to download Console_Getopt-1.2.3.tgz (4,011 bytes) ...done: 4,011 bytes Could not get contents of package "/tmp/pear/cache/Console_Getopt-1.2.3.tgz". Invalid tgz file. Download of "pear/Console_Getopt" succeeded, but it is not a valid package archive Error: cannot download "pear/Console_Getopt" Download failed upgrade failed $ pear list Installed packages, channel pear.php.net: ========================================= Package Version State Archive_Tar 1.3.2 stable Console_Getopt 1.2.2 stable PEAR 1.5.4 stable Structures_Graph 1.0.2 stable
 [2007-08-19 22:27 UTC] cellog (Greg Beaver)
this is a support issue - please write to pear-general@lists.php.net as others may have experienced this and may be able to provide a solution. The best I can offer is to re-install PEAR from http://pear.php.net/go-pear.phar If this fails, there is a configuration problem in your PHP environment.
 [2007-08-23 01:16 UTC] vorapoap (Vorapoap Lohwongwatana)
I have the same problem too when I tried to install CodeGen today. I also downloaded go-pear and reinstall pear nothing helps PEAR Version: 1.6.1 PHP Version: 5.2.3 Zend Engine Version: 2.2.0 Running on: Linux mail 2.4.30-bs #2 SMP Sun Feb 5 01:44:24 ICT 2006 i686
 [2007-08-23 01:41 UTC] vorapoap (Vorapoap Lohwongwatana)
I would like to add more info about this. I just have a fresh upgrade to PHP 5.2.3 And haven't installed anything else. More update is.. I can use 'pear install CodeGen-1.0.4.tgz' from /tmp/pear/install as well CodeGen_PECL-1.1.0
 [2007-08-23 18:30 UTC] johnwards (John Wards)
I have the same issue installing something with pear. http://www.symfony-project.com/forum/index.php/t/8320/ I have downgraded to a previous version as well as upgrading to a new version and it still doesn't work. I am able to install the exact same application on my dev box using pear so its not the application. What causes the "Invalid tgz file" error, what can we do to back trace it?
 [2007-10-03 23:47 UTC] cos (Ofer Inbar)
I'm having the same problem with PHP 5.2.4 on RedHat EL4. Some Pear libraries do install correctly, some do not. For example: downloading Mail-1.1.14.tgz ... Starting to download Mail-1.1.14.tgz (17,537 bytes) ......done: 17,537 bytes install ok: channel://pear.php.net/Mail-1.1.14 downloading Mail_Mime-1.5.2.tgz ... Starting to download Mail_Mime-1.5.2.tgz (22,176 bytes) ........done: 22,176 bytes Could not get contents of package "/tmp/pear/cache/Mail_Mime-1.5.2.tgz". Invalid tgz file. Download of "pear/Mail_Mime" succeeded, but it is not a valid package archive Error: cannot download "pear/Mail_Mime" I can verify that the file /tmp/pear/cache/Mail_Mime-1.5.2.tgz was successfully downloaded, and is a valid gzip'ed tar file with a package.xml and the rest of the files. Now here's the interesting bit: I made two PHP 5.2.4 RPMs, custom built. One has --enable-debug on the ./configure line, the other does not. That is the ONLY difference between the two other than the package version number (one is php-5.2.4-2 and the other is php-5.2.4-2d), and they both use the exact same PHP source tar file. When I install the one without --enable-debug, all Pear packages install correctly, no errors. When I install the PHP built with --enable-debug, I get the errors described above. #php --version PHP 5.2.4 (cli) (built: Sep 20 2007 14:07:17) Copyright (c) 1997-2007 The PHP Group Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies #pear -V PEAR Version: 1.6.1 PHP Version: 5.2.4 Zend Engine Version: 2.2.0