Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.9.5

Bug #11166 NetPBM save() command uses wrong filename
Submitted: 2007-05-28 15:34 UTC
From: markvds Assigned: dufuz
Status: Closed Package: Image_Transform (version 0.9.1)
PHP Version: Irrelevant OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2007-05-28 15:34 UTC] markvds (Mark Van der Sanden)
Description: ------------ In the NetPBM driver, the save() command lacks a space between the filename and the redirect parameter ('2>/dev/null'). This results in the wrong filename (it has a '2' appended). The command that gets executed: /usr/bin/jpegtopnm '/tmp/file.jpg'|/usr/bin/pnmtojpeg > "/tmp/file.jpg.new"2> /dev/null Test script: --------------- $filename = '/tmp/file.jpg'; $it = Image_Transform::factory('NetPBM'); $it->load($filename); $it->save($filename . '.new'); Expected result: ---------------- It should create a new file called '/tmp/file.jpg.new' Actual result: -------------- It creates a new file called '/tmp/file.jpg.new2'

Comments

 [2007-05-28 16:39 UTC] dufuz (Helgi ├×ormar)
Duplicate of bug #11165
 [2007-05-28 20:29 UTC] markvds (Mark Van der Sanden)
I can't view bug #11165 - it says that 'the user has not confirmed identity'. Also, I can't re-send the confirmation e-mail. So please set the status of 11165 to 'duplicate' and let this one open. Thanks!
 [2007-05-28 20:56 UTC] jausions (Philippe Jausions)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.