Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.4.0

Bug #9472 package not installable
Submitted: 2006-11-26 14:34 UTC
From: glen at delfi dot ee Assigned: cweiske
Status: Closed Package: PHP_Fork (version 0.3.0)
PHP Version: 5.2.0 OS: PLD Linux
Roadmaps: (Not assigned)    
Subscription  


 [2006-11-26 14:34 UTC] glen at delfi dot ee (Elan Ruusam√§e)
Description: ------------ glen@builder-ac /tmp $ sudo pear install PHP_Fork-beta pear/PHP_Fork requires PHP extension "pcntl" pear/PHP_Fork requires PHP extension "shmop" pear/PHP_Fork requires PHP extension "posix" Invalid Dependency No valid packages found install failed glen@builder-ac /tmp $ pear -V PEAR Version: 1.5.0a1 PHP Version: 5.2.0 Zend Engine Version: 2.2.0 Running on: Linux builder-ac 2.6.13.5-1smp #1 SMP Thu Feb 9 02:45:39 EET 2006 i686

Comments

 [2006-11-27 18:54 UTC] glen at delfi dot ee
just for the record, the version it attempted to install and failed was "0.3.0 (beta) was released on 2005-03-24"
 [2006-11-28 08:19 UTC] lucamariano at php dot net (Luca Mariano)
Thank you for taking the time to write to us, but this is not a bug. The purpose of PHP_Fork is to implement a OO interface to the PHP extension pcntl. So this ext is required. the posix ext is required to take the control over multiple php processes. In order to implement IPC (inter process communication) the shmop module is also required .
 [2006-12-21 15:33 UTC] glen at delfi dot ee
the problem is at install stage, install itself does not need those extensions being present. so most likely the package.xml file is invalid (what the error message actually is saying) anyway, even after installing those extensions the error stays: + /usr/bin/pear -c pearrc -d doc_dir=/docs -d php_dir=/usr/share/pear -d bin_dir=/usr/bin -d data_dir=/usr/share/pear/data -d test_dir=/usr/share/pear/tests install --packagingroot=/home/glen/rpm/pld/BUILD/PHP_Fork-0.3.0 --offline --nodeps /home/glen/rpm/pld/SOURCES/PHP_Fork-0.3.0.tgz + > .install.log + c=1 + cat .install.log Invalid Dependency WARNING: dependencies failed No valid packages found install failed + exit 1 error: Bad exit status from /var/tmp/rpm-tmp.54023 (%prep) RPM build errors: Bad exit status from /var/tmp/rpm-tmp.54023 (%prep) Error: package build failed. (no more info)
 [2007-02-11 07:21 UTC] blgrams at mail dot ru (Rams)
I have same error. And i found that error is generated in PEAR/Dependency2.php line 1090, when i write "print_r($dep) before this: ------ list($newdep, $type) = $this->normalizeDep($dep); if (!$newdep) { return $this->raiseError("Invalid Dependency"); } ------ result was: ------ Array ( [type] => sapi [rel] => has [name] => cli [optional] => no ) ----- So, this variable $dep is send to function ----- function normalizeDep($dep) { $types = array( 'pkg' => 'Package', 'ext' => 'Extension', 'os' => 'Os', 'php' => 'Php' ); if (isset($types[$dep['type']])) { $type = $types[$dep['type']]; } else { return array(false, false); } ----- Here you can see, that type of PHP_Fork is 'cli', but it doesnt present in $types and function returns array(false,false). thats why we see error.
 [2007-06-23 23:05 UTC] cellog (Greg Beaver)
sapi dependency is bogus, it was never implemented in the PEAR Installer and can't be used in package2.xml Remove the sapi dependency and the package will be good
 [2008-10-26 16:47 UTC] cweiske (Christian Weiske)
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/PHP_Fork Fixed in version 0.3.1