Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.9.4

Bug #944 repeatRow() doesn't work with IE(!) as a client
Submitted: 2004-03-04 06:52 UTC
From: jan dot luebke at gmx dot de Assigned:
Status: Bogus Package: Spreadsheet_Excel_Writer
PHP Version: 4.3.0 OS: SuSE 8.2/ Client: Win XP
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 19 + 8 = ?

 
 [2004-03-04 06:52 UTC] jan dot luebke at gmx dot de
Description: ------------ When directly opening the Excel-File with Microsoft Internet Explorer (6.0), the repeatRows()-Function doesn't work. If you choose to save the file do disk and then open it, the repeatRows get repeatet. BUT: If you use Mozilla (1.6), it doesn't matter if you choose to open or save it (I use the Download-Manager). I don't have a clue how this happens, but it seems like a client-side problem. If you want to test it yourself, just run the following code: Reproduce code: --------------- <?php require_once 'Spreadsheet/Excel/Writer.php'; $workbook = new Spreadsheet_Excel_Writer(); $worksheet =& $workbook->addWorksheet('Sheet1'); $workbook->send('test.xls'); $worksheet->write(0, 0, 'first Row (should appear on every page'); $worksheet->repeatRows(0,0); // <- Doesn't work // Fill some pages for ($i=3; $i < 100; $i=$i+3) { $worksheet->write($i, 0, 'somedumbtext'); } $workbook->close(); ?> Expected result: ---------------- The row should get repeated no matter if I choose to open or save the file. Actual result: -------------- The row doesn't get repeatet if I choose to open. Hope this description helps. I haven't checked, but this bug might be related to the bug #581 (RepeatColumns).

Comments

 [2004-06-04 14:17 UTC] scottfishr at aol dot com
For what we us this program for this is the only bug that really needs to be fixed. Has anyone come up with any sort of work around for this? I am using IE6 and get the same exact results as the original submission.
 [2004-06-23 14:29 UTC] jan at traum-projekt dot com
Microsoft Excel XP has a problem with files named filename[1].xls - every file that is direktly opended by IE out of its cache is renamed in this style and get excel mixed up. So... it seems to be an excel-problem not Spreadsheet_Excel_Writer. Try it by renaming a local file to bla[1].xls and open it... btw: the behavior has some more effects: - You can't set panes with Spreadsheet_Excel_Writer - you can't rename the worksheet ...and so on I hope that helps! Jan
 [2004-09-30 20:31 UTC] casep at tuxpan dot com
Ok, but if you directly from Excel create a file with name dummy[1].xls it does not happens. Or even if you create a file dummy.xls and then rename it to dummy[1].xls. But, if you save the PEAR generated file as report.xls it's ok, but after remame it to report[1].xls there is no repeated rows :-(
 [2004-11-09 13:58 UTC] todoit at rambler dot ru
I have the same problem, but i don't use this function. Just if open file directli form IE - my xls dosnt work. If i save file (never mind which name i call it) it's opened ok. There is a problem and how fix it?
 [2004-11-29 14:54 UTC] linux at mbaierl dot com
Any update until now? This bug is open since March...
 [2005-03-03 19:30 UTC] spowers at gotoami dot com
I cant seem to get this to work at all. I've tried firefox 1.0 and IE 6.0. None of the work arounds posted here seem to work for me, and even if they did arent practical for my application. This bug (and the repeat cols bug) should def be top priority.
 [2005-04-26 13:42 UTC] wongmanii at hotmail dot com
Hi, Is there really no way to use this Spreadsheet_Excel_Writer with an already existing file??? Couldn't we change something in the source code to make that feasible? It does not seem so difficult... What do you think?
 [2006-03-20 17:08 UTC] chris at nospam dot crystalfusion dot com (Chris)
I find the same issue with Internet Explorer 7 Beta 1. This is a big issue since it is one of the reasons I used Excel instead of trying to format HTML or a PDF.
 [2006-06-08 18:10 UTC] somekindofemail at anemailaddress dot com (Jus)
I've got the same problem (repeatRows doesn't work) when sending the spreadsheet as an attachment in an email. When I receive and open the email from entourage, the rows do not repeat, but when I receive and open the same email with mail (mac), the rows do repeat. What is up with this?
 [2007-01-16 16:20 UTC] alessandro at acqualba dot it (alessandro pasotti)
I can confirm this behaviour direct excel opening from MSIE 6 : no repeat download + save to disk + open : repeat ok BTW it seems an excel-related problem. I will test the effect of sending different headers, will report positive results here (if any).
 [2007-11-13 19:54 UTC] robny (Rob Newyork)
Does anyone have a better solution for this problem? I can confirm the behavior of the original poster - running in IE7 and Excel 2003 SP2.
 [2008-11-24 11:29 UTC] body (Yerbol Nyssanbekov)
I have the same problem with IE 7. Any solutions since 1 year? Please help.
 [2008-11-24 11:33 UTC] body (Yerbol Nyssanbekov)
Or are there any replace functions for this ? ...
 [2008-11-24 11:54 UTC] body (Yerbol Nyssanbekov)
The function is working when i remove $xls->setVersion(8); when it is not removed it doesn't work...
 [2009-07-30 20:14 UTC] progi1984 (Franck Lefevre)
I just made a hexadecimal diff between two excel files (one opened from IE (with the problem) and the another one saved from IE (with no problem)). And there is a difference :this is the date for the generation which is saved in file.
 [2009-07-30 20:31 UTC] progi1984 (Franck Lefevre)
Others tests : The first file is : test150731.xls (file saved, so no problem) The Second file is test150735[1].xls (file opened, so problem) I open the second file and i haven't the repetition of first line. I close it. I rename it to test150735.xls. I open it. I have the repetition of first line. I close it. I rename it to test150735[1].xls. I open it. I haven't the repetition of first line. So the bug come from Excel. After some searchs in internet, my answer is right. http://support.microsoft.com/kb/306656/en-us http://php.kennedydatasolutions.com/blog/2008/02/05/internet-explorer-breaks-excel-pivot-tables/ And the answer is : Internet Explorer adds ‘[X]’ to the end of the file name when storing the file in the IE temp folder, where X represents an incrementing integer based on the number of downloads of the same file, and the square brackets are illegal characters for file names in Windows. SO the problem is not SpreadSheet_Excel_Writer but the Excel software.
 [2009-08-05 13:54 UTC] progi1984 (Franck Lefevre)
-Status: Open +Status: Bogus
Sorry, but your problem does not imply a bug in PEAR itself. For a list of more appropriate places to ask for help using PEAR, please visit http://pear.php.net/support/ as this bug system is not the appropriate forum for asking support questions. Thank you for your interest in PEAR. As said in my last comment, it's an Excel bug.