Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.3

Bug #9381 Can not use gettext with tr_TR locale
Submitted: 2006-11-19 10:46 UTC
From: turkay dot eren at gmail dot com Assigned: aharvey
Status: Bogus Package: DB (version 1.7.6)
PHP Version: 5.2.0 RC4 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2006-11-19 10:46 UTC] turkay dot eren at gmail dot com (Eren Türkay)
Description: ------------ I can't use DB package with gettext (tr_TR) When i change the language veriable, it works. Test script: --------------- Here is the first bug i see; i can't get query result. http://repo.pardus-linux.nl/DB_BUG.1.txt And here is the second, PEAR doesn't handle the exception http://repo.pardus-linux.nl/DB_BUG.2.txt

Comments

 [2007-01-10 08:04 UTC] aharvey (Adam Harvey)
This is a bug in PHP, rather than PEAR DB. The problem is that calling methods with capital I in their name doesn't work when the locale is set to Turkish -- I presume this is an outcome of the fact that lowercase I in Turkish is not i, as it is in most other languages that use the Latin alphabet. I've filed http://bugs.php.net/40086 to cover the bug in PHP itself, and will close this bug accordingly.