Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.10

Bug #8687 Incorrect handling of default values for non-modal unseen pages.
Submitted: 2006-09-14 05:55 UTC
From: kim at conealley dot net Assigned: avb
Status: Closed Package: HTML_QuickForm_Controller (version 1.0.6)
PHP Version: 5.1.6 OS: Debian GNU/Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 47 - 27 = ?

 
 [2006-09-14 05:55 UTC] kim at conealley dot net (Kim Fredenberg)
Description: ------------ When setting default values for checkboxes and multiple select fileds on a tabbed Controller then the default values are not applied is the page is not physically visited. The problem is due to the fact that the components to which the default values should be applied think they have been submitted and thus applies the submitted value, which is empty on unseen pages. Adding $page->_flagSubmitted = false; on line 245 in Controller.php after page =& $this->_pages[$key]; shoule fix the problem (but it must be thoroughly). this since applying defaults now works and _flagSubmitted is reset to true later on in the loadValues method.

Comments

 [2006-09-14 05:56 UTC] kim at conealley dot net
(but it must be thoroughly) <- What is was about to say that it must be thoroughly tested to see that it does not break anything else.
 [2006-10-08 10:07 UTC] avb (Alexey Borzov)
Fixed in release 1.0.7