Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.2

Bug #791 Links in HTML format email do not work
Submitted: 2004-02-18 21:24 UTC
From: cryogen at mac dot com Assigned:
Status: Bogus Package: Mail_Mime
PHP Version: 4.3.4 OS: OS X 10.2.3
Roadmaps: (Not assigned)    
Subscription  


 [2004-02-18 21:24 UTC] cryogen at mac dot com
Description: ------------ I created a simple email below and generated it using the example for mail_mime from the documentation. a simple link I included in the file as "<a href="http://text.php">Test Link</a>" would show up in the email as "Test Link <http://test.php>". I could not get any links to work in my email. However, by adding empty table tags at the end of the email form (see below), all of the links started working! Reproduce code: --------------- <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> <HTML> <HEAD> <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ISO-8859-1"> <TITLE>EMC - Email</TITLE> <LINK REL=STYLESHEET TYPE="text/css" HREF="{stylesheet}"> </HEAD> <BODY> {con_f_name}:<BR><BR> Thank you for taking time to register with the EcoLogical Mail Coalition. By participating, you are helping {directory_name} reduce waste and increase efficiency for everyone.<BR><BR> <B>If you haven't entered your location/department's employee records already, please take a few minutes now and LogIn at the EcoLogical Mail Coalition's special <a href="http://www.classjuggler.com">Test Link</a> exclusively for {directory_name} participants. LogIn using your e-mail address and the password you provided ({p_word}).</B><BR><BR> Once logged in, you can view all of the records that have been entered to date from your location/department. We are asking participants to enter all former employees still receiving standard-class mail (e.g., catalogs, magazines, brochures, postcards). If you are not sure who these people are, simply enter all of the employees who have left your location/department during the last five years.<BR><BR> When employees leave in the future, please remember to take a minute to LogIn and add their information; this will help to get those undeliverable names off of marketers' mailing lists quickly. In addition to entering former employees, you also can enter employee changes of address (e.g., transfer to another location) to help marketers update their lists and reduce undeliverable mail.<BR><BR> If you have any questions or problems, please e-mail me or call me at {key_con_phone}.<BR><BR> Thanks again for participating. Not only are you helping {directory_name} reduce costs (<I>about $18 per former employee</I>), you're helping us reduce the amount of solid waste generated (<I>as much as 100 pounds per former employee</I>) and save trees (<I>one per former employee</I>).<BR><BR> Sincerely,<BR><BR> <I>{key_con_f_name} {key_con_l_name}</I><BR> {key_con_title} {key_con_phone} <TABLE><TR><TD></TD></TR></TABLE> </BODY> </HTML> Expected result: ---------------- Inserting the link in the email should have worked without the dummy table tags at the end of the email. I cannot explain this behaviour? I am baffled as to why adding the empty table tags fixes the links? But it works and is nw in all of my emails.

Comments

 [2004-02-18 21:40 UTC] cryogen at mac dot com
Okay, in trying to resolve my problem while waiting for a response to this bug, I may have a solution: I changed the header of the HTML part of my message to: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"> <HTML> <HEAD> <META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=ISO-8859-1"> <TITLE>EMC - Email</TITLE> <LINK REL=STYLESHEET TYPE="text/css" HREF="{stylesheet}"> </HEAD> <BODY> Adding the DOCTYPE and META tags. This seemed to fix the problem. If these are required to generaste an HTML email, PLEASE update the documentation found on the example pages to describe what is required when setting up the HTML tags for an HTML email. The example only shows the <html> and <body> tags. Please make this more clear for us mere mortals who are trying to understand how to use the wonderful PEAR classes.
 [2004-02-25 18:13 UTC] gschlossnagle at php dot net
This is a mail client issue and has nothing to do with the mime encoding of the message. Unfortunately, because different email clients render rich-text mails differently, the only way to make the documentation accurate is to say 'it depends on the client.'