Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.12

Bug #7419 Check inputs in PEAR_PackageFile_v2_rw
Submitted: 2006-04-19 03:01 UTC
From: davey Assigned: cellog
Status: Closed Package: PEAR (version 1.4.9)
PHP Version: 5.1.2 OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  


 [2006-04-19 03:01 UTC] davey (Davey Shafik)
Description: ------------ When using PEAR_PackageFileManager if you set the 'required' argument in addPackageDepWithChannel() to 'true' (or anything really) instead of 'required' or 'optional' then it causes issues when trying to create the package.xml: The error is thus: XML names may only start with letter or underscore The bug is that PEAR_PackageFile_v2_rw doesn't check the input. It should probably allow required/optional and true/false. - Davey

Comments

 [2006-04-25 02:43 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.