Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.5.0b5

Request #6907 PDO based drivers (was: SQLite Version 3 Support)
Submitted: 2006-02-23 15:24 UTC
From: priplatv at netscape dot net Assigned:
Status: Open Package: MDB2
PHP Version: 5.1.2 OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 25 + 8 = ?

 
 [2006-02-23 15:24 UTC] priplatv at netscape dot net (Vlad)
Description: ------------ Could you please let us know, whether it is the intention to support version 3 of SQLite within the DB package, together with version 2 obviously, and by when? With the bundled availability of SQLite Version 3 within PHP 5.x it would be a big advantage to have this support within PEAR, allowing developers to move to the latest (and better) version of SQLite easily. Many thanks.

Comments

 [2006-02-25 12:10 UTC] lsmith
This would require writing a PDO based driver. An important task in its own right.
 [2006-03-11 10:03 UTC] lsmith
DB is in maintenance mode, new features should go into MDB2 and we can consider then if its feasible to backport this.
 [2007-12-12 14:12 UTC] zabuch (Tomek Mu.)
What is the status of PDO drivers in MDB2? Are you planning to replace existing drivers with the versions that will use PDO?
 [2007-12-13 09:39 UTC] quipo (Lorenzo Alberton)
No plan to replace anything, no. Sure, PDO drivers would be nice, but I don't have time to write them. There are talks and even some code drafts about a new PDO-based DBAL: http://thread.gmane.org/gmane.comp.php.pear.devel/43942
 [2008-04-12 23:59 UTC] dufuz (Helgi Þormar Þorbjörnsson)
There's now a SQLite3 extension in pecl, I guess you could make a driver against that http://pecl.php.net/package/sqlite3 Not bundled by default but well, perhaps a better approach compared to doing a PDO thing
 [2009-03-08 17:58 UTC] metala (Marin Ivanov)
I have written a driver (PDO + Sqlite3). http://downloads.metala.org/pear/MDB2/MDB2_Driver_pdoSqlite.tar.bz2 But it's considered unstable. I haven't tested it much. I wrote it for a night a day ago, and today I added a workaround for the "database is locked" problem. So far, there were no major problems, I think It can be used for testing, but not for production purposes. Here is the main driver part: http://downloads.metala.org/pear/MDB2/Driver/pdoSqlite.php.txt
 [2012-02-05 09:57 UTC] soren (Soren Stoutner)
Seeing as how SQLite 2 is no longer supported upstream, this package has very little use until it is updated to support PDO or SQLite 3. For example, the Roundcube package can no longer use SQLite for a backend. http://trac.roundcube.net/ticket/1488332