Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.11

Bug #6663 Notice about reference passing
Submitted: 2006-02-02 07:41 UTC
From: yonman at nsa dot co dot il Assigned: cipri
Status: Closed Package: Mail_Mime (version 1.3.1)
PHP Version: 5.1.1 OS: Windows xp
Roadmaps: 1.4.0    
Subscription  
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes. If this is not your bug, you can add a comment by following this link. If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
2007-05-05 15:09 UTC
Package:
Bug Type:
Summary:
From: yonman at nsa dot co dot il
New email:
PHP Version: Package Version: OS:

 

 [2006-02-02 07:41 UTC] yonman at nsa dot co dot il
Description: ------------ When using the Mail mime class normaly, two notices are displayed about incorrect reference passing from methods within the Mail mime class. Test script: --------------- $message = new Mail_mime( SYSTEM_MAIL_MIME_CRLF ); $message->_build_params[ 'html_charset' ]= 'UTF-8'; $message->_build_params[ 'text_charset' ]= 'UTF-8'; $message->_build_params[ 'head_charset' ]= 'UTF-8'; $message->setTXTBody( $strText ); $message->setHTMLBody( $strHTML ); $body = $message->get( ); $extraheaders = array( "From" => 'someone@somewhere.foo' , "Subject"=> 'subject' ); $headers = $message->headers( $extraheaders ); $mail = Mail::factory( "mail" ); $mixedResponse = $mail->send( $mixedTo, $headers, $body); Expected result: ---------------- Mail should be sent silently and normally. Actual result: -------------- <b>Notice</b>: Only variable references should be returned by reference in <b>E:\Program Files\xampp\php\pear\Mail\mime.php</b> on line <b>375</b><br /> <b>Notice</b>: Only variable references should be returned by reference in <b>E:\Program Files\xampp\php\pear\Mail\mime.php</b> on line <b>593</b><br />

Comments

 [2006-02-02 13:22 UTC] cipri
Please do not submit the same bug more than once. An existing bug report already describes this very problem. Even if you feel that your issue is somewhat different, the resolution is likely to be the same. Because of this, we hope you add your comments to the existing bug instead. Thank you for your interest in PEAR. Duplicate of Bug #5333
 [2007-05-05 15:09 UTC] cipri (Cipriano Groenendal)
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/Mail_Mime Fixed in 1.4.0