Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.0

Bug #6581 Functions missing in func_array.php
Submitted: 2006-01-25 17:15 UTC
From: 0x33 at free dot fr Assigned: farell
Status: Closed Package: PHP_CompatInfo
PHP Version: 5.1.2 OS: Debian Sarge
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 23 - 4 = ?

 
 [2006-01-25 17:15 UTC] 0x33 at free dot fr
Description: ------------ When doing a PHP_CompatInfo_Cli->run() on the file below, the package does not report any extensions required for this piece of code to run, whereas it should report that the script is using BCMath and PCRE extensions. And, also, the minimum version reported is not truly exact. The source of the problem is that in data/func_array.php, all the functions with version number 3 are removed (in scripts/updateVersionInfo.php). But this is bad, because, for example, you can compile PHP with --disable-bcmath or --without-pcre-regex (even the latest PHP 5.1 !) IMHO, PHP_CompatInfo should report that the following piece of code requires extentions BCMath & PCRE to run, and at least PHP 3.0.9 (for preg_match). Test script: --------------- <?php $nb = bcsub(1.234, 5, 4); if (preg_match('/^-/', $nb)) { echo 'minus'; } ?> Expected result: ---------------- +----------+---------+------------+------------------+ | File | Version | Extensions | Constants/Tokens | +----------+---------+------------+------------------+ | test.php | 3.0.9 | bcmath | | | | | pcre | | +----------+---------+------------+------------------+ Actual result: -------------- +----------+---------+------------+------------------+ | File | Version | Extensions | Constants/Tokens | +----------+---------+------------+------------------+ | test.php | 4.0.0 | | | +----------+---------+------------+------------------+

Comments

 [2006-06-15 22:37 UTC] farell (Laurent Laville)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. *** This issue has been fixed and will be available with next release 1.0.2 Laurent