Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.13.1

Bug #648 Test depends on to new a SQLite
Submitted: 2004-02-01 03:58 UTC
From: cipri Assigned: jon
Status: Closed Package: Log
PHP Version: 4.3.4 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2004-02-01 03:58 UTC] cipri
Description: ------------ The sqlite.phpt file uses a function called sqlite_fetch_single(). This function seems to be quite new, did not yet exist in my php/sqlite version, and is unneeded by Log/Sqlite.php itself. Replacing the sqlite_fetch_single with sqlite_fetch_string made it work for me. Reproduce code: --------------- pear run-tests /path/to/pear/tests/Log/tests/ Expected result: ---------------- PASS Log: Sqlite Handler [/usr/share/pear/tests/Log/tests/sqlite.phpt] Actual result: -------------- FAIL Log: Sqlite Handler [/usr/share/pear/tests/Log/tests/sqlite.phpt]

Comments

 [2004-02-01 07:40 UTC] jon
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.