Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.3.7

Request #4711 tree structure don't need an Doubly-linked list
Submitted: 2005-06-29 20:50 UTC
From: fabio at bs2 dot com dot br Assigned:
Status: Bogus Package: Tree
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2005-06-29 20:50 UTC] fabio at bs2 dot com dot br
Description: ------------ I think that an node of tree structure only need a parent, and not a parent and Doubly-linked list. LiveUser package of PEAR in complex type has an tree structure in group hierarchi, and I'm trying to show this hierarchi, but this class require left and right fields and table that link parent and childs not have this fields. My change request is remove or change the right and left fields be optional. Because tree structure don't need an Doubly-linked list.

Comments

 [2006-03-30 22:08 UTC] cross (colin)
Why not use the DBsimple type (which only requires an ID and parent ID)?
 [2006-04-08 19:54 UTC] dufuz (Helgi ├×ormar)
Thank you for taking the time to write to us, but this is not a bug. Colin is straight on about this ...