Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.7

Bug #412 Invalid INSERT syntax
Submitted: 2003-12-12 10:19 UTC
From: yunosh Assigned: eru
Status: Closed Package: Services_Weather
PHP Version: 4.3.4 OS: Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 23 + 7 = ?

 
 [2003-12-12 10:19 UTC] yunosh
Description: ------------ If running buildMetarDB -a, a lot of invalid INSERT statements are generated, like: INSERT INTO metarAirports VALUES(3896,--,---,'ZYTX','Shenyang / Taokian','','China',2,41.8,123.4,35,-2617.4026,3969.4993,4251.2441) All in all 3896 airports have been added correctly, but 2583 had this syntax error.

Comments

 [2003-12-12 10:54 UTC] eru at php dot net
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. The error occured, because of a faulty check when handling "--" fields. Will rerelease asap.
 [2003-12-12 16:17 UTC] yunosh
Works fine now, beside one single data row: Line 2523: INSERT INTO metarAirports VALUES(2522,null,null,'KCIR','Cairo, Cairo Regional Airport,IL','United States','4',37-03-52N,-89.2194,0,0,86.8885,0,-6377.5581) DB Error: no such field
 [2003-12-12 17:10 UTC] eru at php dot net
This is an error in the sources the NOAA provides, I've already informed them. The Problem is, that the name of the airport "Cairo, Cairo Regional Airport" and its state "IL" are separated by "," and not by ";". Another error in the sources is, that one airport on Saipan has "Northern Marianas" instead of "GU" as state. They will correct this in their next release. -> closing