Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.5

Bug #3671 Installing package features doesn't work as expected
Submitted: 2005-03-02 16:38 UTC
From: yunosh Assigned: cellog
Status: Closed Package: PEAR
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2005-03-02 16:38 UTC] yunosh
Description: ------------ I expect this to update my PEAR package with the webinstaller bundle: $ pear install pear#webinstaller Instead, I get: Failed to download pear/PEAR_Frontend_Web within preferred state alpha", latest release is version 0.4, stability "beta", use "channel://pear.php.net/PEAR_Frontend_Web-0.4" to install Failed to download pear/PEAR_Frontend_Gtk within preferred state alpha", latest release is version 0.3, stability "beta", use "channel://pear.php.net/PEAR_Frontend_Gtk-0.3" to install Failed to download pear/PEAR_Frontend_Web within preferred state alpha", latest release is version 0.4, stability "beta", use "channel://pear.php.net/PEAR_Frontend_Web-0.4" to install Skipping package "pear/PEAR", already installed as version 1.4.0a2 No valid packages found install failed

Comments

 [2005-03-02 21:53 UTC] cellog
this is partially because Pierre and Alan need to release the frontend packages (*ahem*), but the main issue is that the error messages do not indicate this is the problem.
 [2005-03-17 04:57 UTC] cellog
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.