Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.0b4

Bug #3624 CRITICAL: non-ISO-8859-1 characters in package.xml must be entitied
Submitted: 2005-02-27 23:59 UTC
From: danielc Assigned: antonio
Status: Closed Package: HTTP_Upload
PHP Version: Irrelevant OS: n/a
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 4 + 20 = ?

 
 [2005-02-27 23:59 UTC] danielc
Description: ------------ Antonio's name is the problem... Your package.xml file contains characters outside the ISO-8859-1 character set (for example, letters with umlats, tildes etc). This causes problems when people install your program using the new 1.4.x series of PEAR. It is very important this issue be addressed as soon as possible. How you address it depends on how you create your package.xml files: a) If you generate your package via PEAR_PackageFileManager, upgrade your version of PEAR to 1.4.0a2 then re-run the packge file manger script. The new version of PEAR should automatically take care of the character conversions. b) If you write your package.xml files by hand, locate the problematic characters in the file and replace them with "entities." Examples: o with an umlat = ö n with a tilde = ñ A list of the most common entities can be found at: http://www.oasis-open.org/docbook/xmlcharent/0.1/iso-lat1.ent If the characters you need aren't in that list, go to http://www.oasis-open.org/docbook/xmlcharent/0.1/index.shtml and look at the other entity lists. Once the problematic characters have been replaced with entities in the package.xml file, please commit it to CVS and make a new release as soon as possible. If you do not do this, users will recieve the following error: CRITICAL ERROR: package.xml downloaded does not match value returned from xml-rpc Thanks.

Comments

 [2005-02-28 20:57 UTC] antonio
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. http://cvs.php.net/co.php/pear/HTTP_Upload/package.xml?r=1.21#33