Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.8.1

Bug #2801 Why require PHP 5?
Submitted: 2004-11-21 13:03 UTC
From: pear-net-idna-2004 at ryandesign dot com Assigned: mnix
Status: Closed Package: Net_IDNA
PHP Version: 4.3.9 OS: N/A
Roadmaps: (Not assigned)    
Comments Add Comment Add patch

Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem : 26 - 9 = ?

 [2004-11-21 13:03 UTC] pear-net-idna-2004 at ryandesign dot com
Description: ------------ Net_IDNA 0.4.0 won't install unless PHP >= 5.0.0RC1. But looking at your code, you have a PHP 4 implementation, and if I force the installation to ignore dependencies (sudo pear install -f -n Net_IDNA) then it seems to work just fine in PHP 4.3.9. So why are you requiring PHP 5? Reproduce code: --------------- sudo pear install -f Net_IDNA Expected result: ---------------- successful installation Actual result: -------------- error message that PHP 5 is required


 [2005-02-01 10:55 UTC] mso
This is merely a problem of NetIDNA, this is a general issue of PEAR.
 [2005-02-01 11:14 UTC] dufuz
Actually I shall reprash what ryandesign said, you shouldn't be requiring PHP5 if there is a PHP4 file in Net_IDNA. So have a required dep of PHP4 v. 4.3.0 or what ever is needed and a optional dep on PHP5, people should be able to understand that, and later when PEAR 1.4.0 comes out then you can go into more complex stuff with package.xml. At least I see no point in having a PHP4 file in there if no one can ever use it.
 [2005-02-01 12:05 UTC] pear-net-idna-2004 at ryandesign dot com
Just to make sure we understand: the PHP4 version seems to work fine! Please do not remove it, as our application depends on it. Yes, I know your code says not to rely on Net_IDNA. Well, we do anyway. You've written the code, it works, now all you need to do is make it possible for people to install it without telling PEAR to ignore its supposed dependencies.
 [2005-02-01 13:15 UTC] mnx
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at package.xml now opts php 4 as required, php 5 as optional