Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.8.1

Bug #2526 Very long execution time / Running in loop?
Submitted: 2004-10-14 10:23 UTC
From: marlow at mail dot ru Assigned:
Status: Bogus Package: Net_IDNA
PHP Version: 4.3.9 OS: Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 35 + 37 = ?

 
 [2004-10-14 10:23 UTC] marlow at mail dot ru
Description: ------------ When giving some special characters to the class it runs in a loop or something, the cpu load is going high and the page isn't loading. Better add this class to pear! I'm using it without problems: http://pear.speedpartner.de/apidoc/I18N_Punycode/ Reproduce code: --------------- e.g. http://idnaconv.phlymail.de/index.php?decoded=%3C%3Edsdsdhttp%3A%2F%2Fidnaconv.phlymail.de%2Findex.php%3Fdecoded%3D%253C%253Edsdsd%26encode%3DEncode%2B%253E%253E&encode=Encode+%3E%3E Expected result: ---------------- Entering special characters as domain name like: !"ยง$%&/()=??<>{[]} Actual result: -------------- Running in a loop

Comments

 [2004-10-14 10:37 UTC] mso
Not enough information was provided for us to be able to handle this bug. Please re-read the instructions at http://bugs.php.net/how-to-report.php If you can provide more information, feel free to add it to this bug and change the status back to "Open". Thank you for your interest in PEAR. The example given works perfectly for me. Could you please provide an example char, which does not work?
 [2005-02-01 10:52 UTC] mso
No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Open". Thank you. This bug could not be confirmed, so it is considered bogus.
 [2005-02-01 11:16 UTC] dufuz
If it's bogus then you mark it as such, thanks.