Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.2.2

Bug #2512 When using a custom valueColumn no pref ever returned
Submitted: 2004-10-12 07:42 UTC
From: aashley at optimiser dot com Assigned: jellybob
Status: Closed Package: Auth_PrefManager
PHP Version: 5.0.2 OS: All
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 43 + 49 = ?

 
 [2004-10-12 07:42 UTC] aashley at optimiser dot com
Description: ------------ When using a custom valueColumn the valueColumn string is stored in a form quoted for using in SQL statements. This makes it impossible for line 209 to retrieve the value from the returned array. My patch to fix this stores the valueColumn as the original valueColumn (Auth_PrefManager::_valueColumn) and the quoted valueColumn (Auth_PrefManager::_valueColumnQuote). I chose to do it this way to minimise the number of function calls needed for setting and deleting preferences. This could just as easily be done to store only the original version and quote it as needed. Patch is available at: http://frood.cernun.net/stuff/PrefManager-custom-valueColumn.patch

Comments

 [2004-11-07 20:15 UTC] jellybob at gmail dot com
Thank you for the patch, I'll apply it to CVS sometime soon and then make a new relase.
 [2005-04-04 23:59 UTC] jellybob
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.