Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.8.5

Bug #2337 Validate::uri doesn't work
Submitted: 2004-09-15 14:04 UTC
From: stefan_saasen Assigned:
Status: Bogus Package: Validate
PHP Version: 4.3.8 OS: Mac OS X
Roadmaps: (Not assigned)    
Subscription  


 [2004-09-15 14:04 UTC] stefan_saasen
Description: ------------ Nearly anything ;-) validates as an URI Reproduce code: --------------- var_export(Validate::uri('')); var_export(Validate::uri('fff')); var_export(Validate::uri('http;//sdfsdf/')); var_export(Validate::uri('http;asdasd//')); Expected result: ---------------- false false false false Actual result: -------------- true true true true

Comments

 [2004-11-08 11:10 UTC] dufuz
Thank you for taking the time to write to us, but this is not a bug. That's actually because it should validate var_dump(Validate::uri('fff', array('allowed_schemes' => array('http')))); Would give you false the URI function isn't only validating URL like http://www.example.com and such, but it takes on what RFC2396 specifies, so please look at that, even look at the RFC and tell us if there is still a problem...