Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.0RC3

Bug #21216 Call to undefined method PEAR::OLE_PPS()
Submitted: 2017-06-02 06:49 UTC
From: wojtassp320 Assigned: ashnazg
Status: Closed Package: OLE (version Unknown)
PHP Version: Irrelevant OS: Linux 4.4.0-78-generic x86_64
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 42 - 40 = ?

 
 [2017-06-02 06:49 UTC] wojtassp320 (Wojtas Sp)
Description: ------------ Error occurs when trying to close xls file Spreadsheet_Excel_Writer_Workbook - >close(). It is caused by changing the name of "OLE_PPS", "OLE_PPS_File", "OLE_PPS_Root" and "OLE" classes constructors form "class name" to __construct in commit 367856d0f54e7784c34d9eb927cc26b57a740882. Constructor names has changed, but there are some references to this methods by old name (e.g.: pear/ole/OLE/PPS/File.php:57 ) Error occurs in PHP 7.0.15

Comments

 [2017-06-20 12:55 UTC] ashnazg (Chuck Burgess)
-Assigned To: +Assigned To: ashnazg
Patch (https://github.com/pear/ole/pull/8)
 [2017-06-20 13:02 UTC] ashnazg (Chuck Burgess)
-Status: Assigned +Status: Closed
PR merged... look for fix in upcoming release.