Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 3.4.2

Bug #20147 phpcs-svn-pre-commit - no more default error report
Submitted: 2013-12-12 22:53 UTC
From: flemm Assigned: squiz
Status: Closed Package: PHP_CodeSniffer (version 1.5.1)
PHP Version: 5.4.22 OS: debian squeeze
Roadmaps: (Not assigned)    
Subscription  


 [2013-12-12 22:53 UTC] flemm (Fabian Lemm)
Description: ------------ on pre-commit hook, no more error reported since v1.5.0 it works on v1.4.8

Comments

 [2013-12-13 04:48 UTC] squiz (Greg Sherwood)
-Status: Open +Status: Feedback -Assigned To: +Assigned To: squiz
The pre-commit hook is still working fine for me. Any chance you could give me more information? Any errors being produced? Is the commit being blocked even though the report doesn't show up? What command are you using in your pre-commit hook file? This is the command I am testing with: /usr/bin/php /path/to/PHP_CodeSniffer/scripts/phpcs-svn-pre-commit -- standard=Squiz --report=summary "$REPOS" -t "$TXN" >&2 || exit 1
 [2013-12-13 14:19 UTC] flemm (Fabian Lemm)
my test with your command was successfull. I used no "--report=xxx". after adding --report=summary, it works. It seem since v1.5.0 there is no more default report set and so phpcs found errors in phpcs-svn-pre-commit, but don't display and no commit will be blocked.
 [2013-12-16 08:22 UTC] squiz (Greg Sherwood)
-Summary: phpcs-svn-pre-commit - no more error report +Summary: phpcs-svn-pre-commit - no more default error report -Status: Feedback +Status: Closed
Thanks a lot for getting back to me; you were 100% right about the default error report being removed from the pre-commit hook. That was a mistake and it has been fixed in this commit: https://github.com/squizlabs/PHP_CodeSniffer/commit/440f23e0089d720776420ed743 275e60d240b99d The work-around is to use --report=full until the next release.