Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 3.4.2

Bug #20133 Allow "HG: <hg_id>" as value for @version tag
Submitted: 2013-11-22 15:29 UTC
From: kguest Assigned: squiz
Status: Closed Package: PHP_CodeSniffer (version 1.5.0RC4)
PHP Version: 5.4.9 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2013-11-22 15:29 UTC] kguest (Ken Guest)
Description: ------------ As I'm using Mercurial for source control, I have "@version HG: <hg_id>" in my docblocks. This leads on to me getting warnings such as the following. "Invalid version "HG: <hg_id>" in file comment; consider "CVS: <cvs_id>" or "SVN: <svn_id>" or "GIT: <git_id>" instead." Running phpcs with the -s switch indicates this is in the PEAR.Commenting.FileComment.InvalidVersion sniff.

Comments

 [2013-11-25 09:46 UTC] squiz (Greg Sherwood)
-Status: Open +Status: Closed -Assigned To: +Assigned To: squiz
Fix committed to github repo: https://github.com/squizlabs/PHP_CodeSniffer/commit/a673c04604d8aaeb092fa226c3 cd21d3400bd1f0
 [2013-11-28 15:45 UTC] kguest (Ken Guest)
Thanks for closing this so quickly :)