Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 3.4.2

Bug #20097 CLI.php throws error in php 5.2
Submitted: 2013-10-14 14:39 UTC
From: sahlex Assigned: squiz
Status: Closed Package: PHP_CodeSniffer (version 1.4.7)
PHP Version: Irrelevant OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2013-10-14 14:39 UTC] sahlex (Alexander Sahler)
Description: ------------ When calling CodeSniffer an error is thrown: Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM, expecting ',' or ';' in /usr/share/php/PHP/CodeSniffer/CLI.php on line 311 Though CodeSniffer is said to depend on php 5.1.x this is obviously wrong. CLI.php uses syntax that is supported with 5.3.x or greater. Please provide new dependency in the description or support old syntax. Best regards, Alexander.

Comments

 [2013-10-23 09:21 UTC] squiz (Greg Sherwood)
-Status: Open +Status: Closed -Assigned To: +Assigned To: squiz
The syntax chosen was just a mistake and PHPCS should still support 5.2. I've committed a fix here: https://github.com/squizlabs/PHP_CodeSniffer/commit/4b615f4e1dd6d3a2961e9e01da becc571e9c842a