Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.0.0a1

Bug #19969 Sniffs with namespace not recognized in reports
Submitted: 2013-06-05 11:02 UTC Modified: 2013-06-12 05:33 UTC
From: thepablick Assigned: squiz
Status: Closed Package: PHP_CodeSniffer (version 1.4.5)
PHP Version: 5.3.25 OS: Mac OS X 10.8.3
Roadmaps: (Not assigned)    
Subscription  


 [2013-06-05 11:02 UTC] thepablick (Pavel Lisa)
Description: ------------ When a sniff is using namespace, it doesn’t get recognized in reports – instead of StandardName.SomeGroup.TheSniffName, it shows unknownSniff. From what I saw in code, it’s caused by identification being based on explode by underscore character, but ignoring the possibility of it being the namespace backslash. The same happens with explaining a (custom) standard.

Comments

 [2013-06-12 05:33 UTC] squiz (Greg Sherwood)
-Status: Open +Status: Closed -Assigned To: +Assigned To: squiz
Fix for report codes committed to github repo: https://github.com/squizlabs/PHP_CodeSniffer/commit/8a71e83f7a3cea61b81adbca5a f5d9bceaf826e7 Fix for explaining standards committed to github repo: https://github.com/squizlabs/PHP_CodeSniffer/commit/51ec16201fb60e00f77850dc8d e69a04e91342be