Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.3.0

Bug #19337 Use of undefined variable
Submitted: 2012-03-16 21:13 UTC
From: tallman Assigned: avb
Status: Closed Package: HTTP_Request2 (version 2.0.0)
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: 2.1.0    
Subscription  


 [2012-03-16 21:13 UTC] tallman (Alexander Marchenko)
Description: ------------ Undefined variable: php_errormsg in /usr/share/pear/HTTP/Request2/Adapter/Socket.php on 326 Best Regards, Alex. Expected result: ---------------- No errors or warnings Actual result: -------------- Error: Undefined variable: php_errormsg in /usr/share/pear/HTTP/Request2/Adapter/Socket.php on 326

Comments

 [2012-03-18 10:28 UTC] doconnor (Daniel O'Connor)
http://php.net/manual/en/reserved.variables.phperrormsg.php Seems odd - the ini set to track errors seems to have failed for you.
 [2012-03-18 13:29 UTC] avb (Alexey Borzov)
-Status: Open +Status: Analyzed -Assigned To: +Assigned To: avb
I can reproduce this if I set track_errors = Off disable_functions = ini_set in my php.ini. Alexander, is your PHP installation configured in similar way? Looks like error_get_last() is the best bet here.
 [2012-03-18 20:20 UTC] avb (Alexey Borzov)
-Status: Analyzed +Status: Closed
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. -- Got rid of track_errors in both places where it was used.