Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.7

Bug #19228 Fatal error: Cannot use object of type PEAR_Error
Submitted: 2012-01-16 15:49 UTC
From: aschuch Assigned: doconnor
Status: Closed Package: Services_Weather (version 1.4.6)
PHP Version: 5.3.6 OS: GNU/Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 31 + 26 = ?

 
 [2012-01-16 15:49 UTC] aschuch (Alexander Schuch)
Description: ------------ Fatal error: Cannot use object of type PEAR_Error as array in /usr/share/php/Services/Weather/Metar.php on line 1845 Services_Weather_Commin::calculateMoonPhase() throws an error in case of an invalid parameter. However, Services_Weather_Metar::getWeather() does not check for that. The problem is still present in current SVN trunk.

Comments

 [2012-08-13 18:04 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Closed -Assigned To: +Assigned To: doconnor
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.