Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 3.4.2

Bug #19114 CodeSniffer checks extension even for single file
Submitted: 2011-12-08 02:34 UTC
From: fin_sn Assigned: squiz
Status: Closed Package: PHP_CodeSniffer (version 1.3.2)
PHP Version: 5.3.8 OS: irrelevant
Roadmaps: (Not assigned)    
Subscription  


 [2011-12-08 02:34 UTC] fin_sn (Jens Radtke)
Description: ------------ CodeSniffer was expected to process any file, regardless of its extension - if it passed as a single file and not as a directory. Since Version 1.3.2 it checks every file for a matching extension and if you don't specify any special one (--extensions), it uses the default settings (CodeSniffer->allowedFileExtensions) instead of skipping the extension check. (In this special case a *.phtml file should be processed...) I'm not sure but it seems to be a issue since commit 47032e12c729c0061e58daf4295f710f38bbb0bf. (See: http://pear.php.net/manual/en/package.php.php-codesniffer.advanced-usage.php)

Comments

 [2011-12-12 10:09 UTC] squiz (Greg Sherwood)
-Assigned To: +Assigned To: squiz
Caused by fix for bug #18709
 [2011-12-12 10:15 UTC] squiz (Greg Sherwood)
-Status: Assigned +Status: Closed
Fixed in git repo: https://github.com/squizlabs/PHP_CodeSniffer/commit/38c4e5f900bc03deecc077cfbe 5caf1f6886cfee