Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.1.4

Bug #18925 Test fails with latest HTTP_Request2
Submitted: 2011-10-23 12:17 UTC
From: remicollet Assigned: doconnor
Status: Closed Package: XML_RPC2 (version 1.1.1)
PHP Version: 5.3.8 OS: GNU/Linux (Fedora 15)
Roadmaps: (Not assigned)    
Subscription  


 [2011-10-23 12:17 UTC] remicollet (Remi Collet)
Description: ------------ Test expects a HTTP_Request2_Exception while a HTTP_Request2_ConnectionException is raised by HTTP_Request2 2.0.0 in tests/phpBackend/client/protocolError.phpt tests/xmlrpcextBackend/client/protocolError.phpt

Comments

 [2011-10-23 12:19 UTC] remicollet (Remi Collet)
$ cat ./XML_RPC2/xmlrpcextBackend/client/protocolError.diff 001- string\(.*\) \"HTTP_Request2_Exception.* 001+ string(935) "HTTP_Request2_ConnectionException: Unable to connect to tcp://rpc.example.com:1000. Error: php_network_getaddresses: getaddrinfo failed: Name or service not known in /usr/share/pear/HTTP/Request2/Adapter/Socket.php on line 154 002+ #0 /usr/share/pear/HTTP/Request2/Adapter/Socket.php(154): HTTP_Request2_Adapter_Socket->connect() 003+ #1 /usr/share/pear/HTTP/Request2.php(923): HTTP_Request2_Adapter_Socket->sendRequest(Object(HTTP_Request2)) 004+ #2 /usr/share/pear/XML/RPC2/Util/HTTPRequest.php(234): HTTP_Request2->send() 005+ #3 /usr/share/pear/XML/RPC2/Backend/Xmlrpcext/Client.php(113): XML_RPC2_Util_HTTPRequest->sendRequest() 006+ #4 /usr/share/pear/test/XML_RPC2/tests/XML_RPC2/xmlrpcextBackend/client/protocolError.php(8): XML_RPC2_Backend_Xmlrpcext_Client->__call('invalidMethod', Array) 007+ #5 /usr/share/pear/test/XML_RPC2/tests/XML_RPC2/xmlrpcextBackend/client/protocolError.php(8): XML_RPC2_Backend_Xmlrpcext_Client->invalidMethod('World') $ cat ./XML_RPC2/phpBackend/client/protocolError.diff 001- string\(.*\) \"HTTP_Request2_Exception.* 001+ string(905) "HTTP_Request2_ConnectionException: Unable to connect to tcp://rpc.example.com:1000. Error: php_network_getaddresses: getaddrinfo failed: Name or service not known in /usr/share/pear/HTTP/Request2/Adapter/Socket.php on line 154 002+ #0 /usr/share/pear/HTTP/Request2/Adapter/Socket.php(154): HTTP_Request2_Adapter_Socket->connect() 003+ #1 /usr/share/pear/HTTP/Request2.php(923): HTTP_Request2_Adapter_Socket->sendRequest(Object(HTTP_Request2)) 004+ #2 /usr/share/pear/XML/RPC2/Util/HTTPRequest.php(234): HTTP_Request2->send() 005+ #3 /usr/share/pear/XML/RPC2/Backend/Php/Client.php(115): XML_RPC2_Util_HTTPRequest->sendRequest() 006+ #4 /usr/share/pear/test/XML_RPC2/tests/XML_RPC2/phpBackend/client/protocolError.php(8): XML_RPC2_Backend_Php_Client->__call('invalidMethod', Array) 007+ #5 /usr/share/pear/test/XML_RPC2/tests/XML_RPC2/phpBackend/client/protocolError.php(8): XML_RPC2_Backend_Php_Client->invalidMethod('World')
 [2011-10-31 13:39 UTC] doconnor (Daniel O'Connor)
I don't see the same on trunk. Is it possible that it's actually just something unique about your network environment and those tests having a lack of proper isolation? $ pear run-tests -r tests/ (snip) 50 PASSED TESTS 56 SKIPPED TESTS 2 FAILED TESTS: /media/Elements_/backup/home/clockwerx/pear- svn/packages/XML_RPC2/trunk/tests/XML_RPC2/regressions/11314.phpt /media/Elements_/backup/home/clockwerx/pear- svn/packages/XML_RPC2/trunk/tests/XML_RPC2/regressions/18258.phpt clockwerx@clockwerx-desktop:/media/Elements_/backup/home/clockwerx/pear- svn/packages/XML_RPC2/trunk$ (annoyingly these failures are a bit due to utf-8 encoding and formatting of the results)
 [2011-11-06 15:30 UTC] doconnor (Daniel O'Connor)
 [2011-11-06 15:31 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Verified
 [2011-11-21 07:58 UTC] doconnor (Daniel O'Connor)
-Status: Verified +Status: Closed -Assigned To: +Assigned To: doconnor
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. Completed: At revision: 319588