Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.6.3

Request #18869 pear/Crypt_GPG requires PHP extension "posix"
Submitted: 2011-09-24 02:39 UTC
From: rhsoftware Assigned: gauthierm
Status: Closed Package: Crypt_GPG (version 1.3.0)
PHP Version: 5.3.8 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2011-09-24 02:39 UTC] rhsoftware (Harald Reindl)
Description: ------------ is it really needed to raise dependencies hosting 500 domains on 20 servers and compile php since years without posix-support and now becasue one pear-package a phprebuild? why? [root@buildserver:~]$ pear upgrade pear/Crypt_GPG requires PHP extension "posix" No valid packages found upgrade failed

Comments

 [2011-09-26 19:21 UTC] gauthierm (Michael Gauthier)
Crypt_GPG has required posix since 0.7.0. Were you actively using Crypt_GPG with no warnings without the posix extension (which should be built by default)?
 [2011-09-26 19:30 UTC] rhsoftware (Harald Reindl)
i was and i am using 1.2.0 the whole time without problems and posix-extension even on the highest error-reporting so "has required posix since 0.7.0" is simply wrong [root@buildserver:~]$ pear list | grep GPG Crypt_GPG 1.2.0 stable [root@buildserver:~]$ cat /etc/php.ini | grep error_reporting error_reporting = E_ALL | E_STRICT [root@buildserver:~]$ autotest.php gnupg /Volumes/dune/buildserver/autotest/parts/gnupg.php OK: gnupg
 [2011-09-26 20:13 UTC] gauthierm (Michael Gauthier)
Ok, I see if you use the homedir option, the posix functions are not called. I will make posix optional.
 [2011-09-26 20:18 UTC] rhsoftware (Harald Reindl)
thank you!
 [2011-09-26 21:18 UTC] gauthierm (Michael Gauthier)
-Status: Open +Status: Closed -Assigned To: +Assigned To: gauthierm
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/ Fixed in Crypt_GPG 1.3.2. Thanks for your report.
 [2011-12-17 22:38 UTC] matrich (Richard Matrich)
Hi gauthierm, I have tried installing Crypt_GPG-1.3.2 and it seems it still requires PHP extension "posix". Detailed error below: C:\wamp\bin\php\php5.4>php pyrus.phar install pear/Crypt_GPG Pyrus version 2.0.0a3 SHA-1: BE7EA9D171AE3873F1BBAF692EEE9165BB14BD5D Using PEAR installation found at C:\wamp\bin\php\php5.4 PEAR2\Pyrus\Installer\Exception: Dependency validation failed for some packages to install, installation aborted PEAR2\Pyrus\Dependency\Exception: pear.php.net/Crypt_GPG can optionally use PHP extension "posix" PEAR2\Pyrus\Dependency\Exception: Cannot install pear.php.net/Crypt_GPG on Win dows Please help. Thanks.
 [2011-12-20 23:48 UTC] gauthierm (Michael Gauthier)
Richard, The last two lines explain what's going on: ... Crypt_GPG can optionally use PHP extension "posix" ... Cannot install pear.php.net/Crypt_GPG on Windows Crypt-GPG is not supported on Windows because Windows doesn't have enough file descriptors. Crypt_GPG requires at least 5 file descriptors to securely pass information like passphrases and external signatures to the gnupg process. See http://pear.php.net/bugs/bug.php?id=13807