Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.13

Bug #18527 I can't install pear DB on php 4.4.7
Submitted: 2011-05-12 06:03 UTC
From: beansoft Assigned: dufuz
Status: Closed Package: PEAR (version SVN)
PHP Version: 4.4.7 OS: red hat 4
Roadmaps: (Not assigned)    
Subscription  


 [2011-05-12 06:03 UTC] beansoft (Jorge Ramirez)
Description: ------------ Installing selected packages.................. Downloading and installing package: PEAR............. Parse error: syntax error, unexpected '(', expecting '}' in /home/httpd/html/cuaed/jddfr_multimedia/educacioncontinua/PEAR- 1.1.6/temp/PEAR/Installer.php on line 811 Thanks

Comments

 [2011-05-12 10:39 UTC] doconnor (Daniel O'Connor)
-Status: Open +Status: Feedback
Thank you for taking the time to report a problem with the package. Unfortunately you are not using a current version of the package -- the problem might already be fixed. Please download a new version from http://pear.php.net/packages.php If you are able to reproduce the bug with one of the latest versions, please change the package version on this bug report to the version you tested and change the status back to "Open". Again, thank you for your continued support of PEAR. Hi Jorge, You appear to be using an exceptionally old version of PEAR. Can you try upgrading? $ pear upgrade pear
 [2011-05-12 20:03 UTC] beansoft (Jorge Ramirez)
Hi Daniel! thanks a lot for you quick response; I've tried to update the pear package and I got this: [root@paluzie ~]# /usr/bin/pear upgrade pear HTTP error, got response: HTTP/1.1 410 Gone Didn't receive 200 OK from remote server. (HTTP/1.1 410 Gone) [root@paluzie ~]# pear upgrade pear HTTP error, got response: HTTP/1.1 410 Gone Didn't receive 200 OK from remote server. (HTTP/1.1 410 Gone) [root@paluzie ~]# I don't have any problem with Internet connection on this server, Yeah, you're right this server has a very old version of PHP and pear, but at this moment there is an application in production there that need to use DB.php. If you have any other idea would be appreciated Thanks in advance
 [2011-06-01 07:18 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Feedback +Status: Bogus
Thank you for taking the time to write to us, but this is not a bug. Your PEAR version is attempting to use an API that was retired over 3 years ago. Here is how you resolve that: http://pear.php.net/news/package.xml.1.0.php
 [2011-06-01 19:23 UTC] beansoft (Jorge Ramirez)
-Status: Bogus +Status: Closed -Assigned To: +Assigned To: beansoft
Thanks a lot, this was very useful. :)
 [2011-06-03 01:59 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Assigned To: beansoft +Assigned To: dufux
 [2011-06-03 02:00 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Assigned To: dufux +Assigned To: dufuz
Oops, that was not suppose to happen. My chrome flipped out here. Sorry for the extra emails.