Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.1.4

Bug #18329 Fatal error in HTTPRequest.php
Submitted: 2011-03-02 19:45 UTC
From: libor Assigned: sergiosgc
Status: Closed Package: XML_RPC2 (version 1.0.8)
PHP Version: 5.3.5 OS: Centos 5.5
Roadmaps: (Not assigned)    
Subscription  


 [2011-03-02 19:45 UTC] libor (Libor Bubik)
Description: ------------ Fatal error: Call to undefined method HTTP_Request2::getStatus() in /XML/RPC2/Util/HTTPRequest.php on line 235

Comments

 [2011-03-02 23:43 UTC] numberxii (Frédéric Marchal)
We encountered the same problem on Ubuntu 10.04, PHP 5.2. HTTP_Request2 2.0.0beta1 beta Net_URL2 0.3.1 beta XML_RPC2 1.0.8 stable Regards
 [2011-03-03 00:08 UTC] remicollet (Remi Collet)
Test suite fails because of this. 71 PASSED TESTS 7 SKIPPED TESTS 30 FAILED TESTS All with "Warning: require_once(HTTP/Request2.php): failed to open stream: No such file or directory... XML/RPC2/Util/HTTPRequest.php on line 45..." According to changelog curl extension is replace by HTTP_REQUEST2 in version 1.1, not in 1.0. I don't find SVN for 1.0 branch (only trunk which is, I think 1.1), branches folder on subversion is empty. http://svn.php.net/viewvc/pear/packages/XML_RPC2/branches/ It seems both 1.1.0beta and 1.0.8 were taged from trunk ? Could you please explain ?
 [2011-03-03 00:13 UTC] remicollet (Remi Collet)
With HTTP_Request2 0.6.0 installed : 101 PASSED TESTS 7 SKIPPED TESTS
 [2011-03-03 12:53 UTC] libor (Libor Bubik)
file /XML/RPC2/Util/HTTPRequest.php line 235 if ($result->getStatus() != 200) throw new XML_RPC2_ReceivedInvalidStatusCodeException('Received non-200 HTTP Code: ' . $request->getStatus() . '. Response body:' . $result->getBody()); Object $request is from HTTP_Request2 class, but in this class is no getStatus() method. I think in line 235 should be variable $result instead of variable $request
 [2011-03-27 00:43 UTC] till (Till Klampaeckel)
-Status: Open +Status: Analyzed -Assigned To: +Assigned To: sergiosgc
Hey Sergio, can you take care of this? Libor gave you the solution and the fix seems trivial. Cheers, Till
 [2011-04-26 20:27 UTC] normelton (Norman Elton)
Has there been any progress here? I realize just saying "me too" doesn't do much good, but I'd love to see 1.0.9 released with this fix. Thanks Norman
 [2011-05-24 21:43 UTC] ronino (Ronny Multrus)
Same here. The problem is that you cannot react to a failed request as the script dies with a fatal error...
 [2011-05-29 19:28 UTC] doconnor (Daniel O'Connor)
-Status: Analyzed +Status: Closed
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. r311547