Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.8.1

Request #17012 Send message body from file but head(ers) from string
Submitted: 2010-01-19 14:04 UTC
From: alec Assigned: jon
Status: Closed Package: Net_SMTP (version CVS)
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2010-01-19 14:04 UTC] alec (Aleksander Machniak)
Description: ------------ Possibility to use data() with file handle is great, but in my system I have such scenario: 1. Prepare the message and sent it using Net_SMTP. 2. Store the message on IMAP server adding some headers e.g. BCC. So, the problem is that adding headers into message file requires its rewriting on disk. It's next 10-20 sec. for 10MB message. If I will able to store headers in variable and body in file, the whole operation will be much faster. I propose to add second argument for data(), containing message head.

Comments

 [2010-01-21 13:57 UTC] alec (Aleksander Machniak)
 [2010-01-21 23:38 UTC] jon (Jon Parise)
-Status: Open +Status: Assigned -Assigned To: +Assigned To: jon
This looks pretty good. I'll try to integrate it soon.
 [2010-01-25 02:45 UTC] jon (Jon Parise)
-Status: Assigned +Status: Closed
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. http://svn.php.net/viewvc?view=revision&revision=293948