Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.29.0

Bug #16036 Bug tracker emails: Patch links broken
Submitted: 2009-03-16 17:23 UTC
From: wiesemann Assigned: dufuz
Status: Closed Package: pearweb (version CVS)
PHP Version: Irrelevant OS:
Roadmaps: 1.18.0    
Subscription  


 [2009-03-16 17:23 UTC] wiesemann (Mark Wiesemann)
Description: ------------ The links to the patches are broken in the bug tracker emails. For example, a bug comment in an email about bug #15985 looked like this: --- The following patch has been added/updated: Patch Name: savant3 URL: patch savant3 ---

Comments

 [2009-03-16 22:29 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Roadmap Versions: +Roadmap Versions: 1.18.0
The URL you just provided seems to work just fine, am I missing something ?
 [2009-03-22 21:49 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Open +Status: Closed -Assigned To: +Assigned To: dufuz
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2009-03-22 22:02 UTC] wiesemann (Mark Wiesemann)
-Status: Closed +Status: Open
The mentioned URL was auto-replaced here in the bug tracker. I'll try it another time with an additional space after the first character: # patch bug:15915;patch:15915;revision:1237721918; ==> this is not an URL that is usable if viewed from an email application, i.e. it's not beginning with 'http://pear.php.net/...' (I'd have replied earlier if I had gotten the email about the new comment or if it would at least have shown up on the pear-bugs list.)
 [2009-03-23 01:08 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Assigned +Status: Closed
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. But I fixed this: http://news.php.net/php.pear.cvs/55830 http://news.php.net/php.pear.cvs/55831 Am I missing something in the bug report ? If so open it again - This has not gone live btw.
 [2009-03-23 01:32 UTC] wiesemann (Mark Wiesemann)
-Status: Closed +Status: Open
You've fixes something that I haven't reported. ;-) My report was about the emails that the bug tracker sends. In the "Previous comments" section, not only "real" comments are shown, but also notifcations about uploaded patches. For an example, look into such an email for bug #15915. The problem is the "patch comments": There is no direct URL to the patch, but only something that starts with "#". I'll try to post another [more complete] example (with the additional space like in my last comment): Previous Comments: ------------------------------------------------------------------------ [2009-03-22 11:38:38] amir The following patch has been added/updated: Patch Name: 15915 URL: # patch bug:15915;patch:15915;revision:1237721918; -----------------------------------------------------------------
 [2009-03-23 03:24 UTC] dufuz (Helgi Þormar Þorbjörnsson)
 [2009-03-23 03:24 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Assigned +Status: Closed
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.