Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 3.4.2

Bug #16001 Notice triggered
Submitted: 2009-03-09 22:49 UTC
From: lsolesen Assigned: squiz
Status: Closed Package: PHP_CodeSniffer (version 1.2.0RC1)
PHP Version: 5.2.5 OS:
Roadmaps: (Not assigned)    
Subscription  


 [2009-03-09 22:49 UTC] lsolesen (Lars Olesen)
Description: ------------ Notice: Undefined offset: -1 in /usr/share/php/PHP/CodeSniffer/Standards/PEAR/Sniffs/WhiteSpace/ObjectOperatorIndentSniff.php on line 89 I can investigate futher which file was parsed if it is neccessary, but it should be possible to avoid it giving a notice? Let me know if you need more information.

Comments

 [2009-03-17 07:47 UTC] squiz (Greg Sherwood)
-Status: Open +Status: Feedback -Assigned To: +Assigned To: squiz
Hi, I will need to know what code caused the problem. PHP_CodeSniffer intentionally prints all error messages because they are an indication that a sniff or the core tokenizing code is not working as intended.
 [2009-03-25 09:44 UTC] squiz (Greg Sherwood)
Are you able to provide that code please?
 [2009-05-02 18:04 UTC] lukas_schroeder (Lukas Schroeder)
Put all of this on a single line to trigger the bug <form class="formcage" action="<?php echo url_for('dummy/'.($form->getObject()->isNew() ? 'create' : 'update').(!$form->getObject()->isNew() ? '?id='.$form->getObject()->getId() : '')) ?>" method="post" <?php $form->isMultipart() && print 'enctype="multipart/form-data" ' ?>> .
 [2009-05-05 11:22 UTC] squiz (Greg Sherwood)
-Status: Feedback +Status: Verified
 [2009-05-05 11:52 UTC] squiz (Greg Sherwood)
-Status: Verified +Status: Closed
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.