Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.10.10

Bug #14779 empty file problem
Submitted: 2008-10-12 16:53 UTC
From: alec Assigned: cipri
Status: Closed Package: Mail_Mime (version CVS)
PHP Version: 5.2.6 OS:
Roadmaps: (Not assigned)    
Subscription  


 [2008-10-12 16:53 UTC] alec (Aleksander Machniak)
Description: ------------ When sending one empty file, two newlines are not added after the last header for the part, only one. As a result, Thunderbird does not show that there is an attached file. Patch: --- mimePart.old 2008-09-29 09:40:35.000000000 +0200 +++ mimePart.php 2008-10-04 20:19:17.073546934 +0200 @@ -257,7 +257,7 @@ } $encoded['body'] = '--' . $boundary . MAIL_MIMEPART_CRLF . - rtrim(implode('--' . $boundary . MAIL_MIMEPART_CRLF , $subparts), MAIL_MIMEPART_CRLF) . MAIL_MIMEPART_CRLF . + implode('--' . $boundary . MAIL_MIMEPART_CRLF , $subparts) . '--' . $boundary.'--' . MAIL_MIMEPART_CRLF; } else {

Comments

 [2009-06-08 10:54 UTC] doconnor (Daniel O'Connor)
-Status: Assigned +Status: Feedback
Want to write me test coverage for this?
 [2009-06-17 16:00 UTC] alec (Aleksander Machniak)
See my comment for #12411
 [2009-12-17 20:05 UTC] alec (Aleksander Machniak)
-Status: Feedback +Status: Closed
This bug has been fixed in SVN. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.