Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0b4

Bug #14383 prepare() makes an erroneus string replacement in a passed query for CLOBs
Submitted: 2008-07-21 20:49 UTC
From: solaris Assigned: quipo
Status: Closed Package: MDB2_Driver_oci8 (version 1.4.1)
PHP Version: 5.2.1 OS: Windows XP Pro, L2.6.9-67.0.4.EL
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 1 + 35 = ?

 
 [2008-07-21 20:49 UTC] solaris (Tonya Torshin)
Description: ------------ Unfortunately I couldn't replicate this behavior if I create a new table with similar fields to ones in my sample (see URL link below), so can't tell why or what fields types combination should be in order to trigger the bug happening. When I output query from oci8.php->prepare() after it has been replaced in $query = substr_replace($query, $value, $p_position, $length); second CLOB 'eats' up a following comma separator. Test script: --------------- http://pastebin.com/f40f2f8b7 Expected result: ---------------- all fields separated by comma properly Actual result: -------------- missing comma after second CLOB argument: http://pastebin.com/f1ba7f5e2

Comments

 [2008-08-11 08:36 UTC] quipo (Lorenzo Alberton)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.