Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.4.2

Bug #13664 setLabelAttributes does not work
Submitted: 2008-04-13 21:29 UTC
From: sharedlog Assigned: farell
Status: Closed Package: HTML_Progress2 (version 2.3.0)
PHP Version: 5.2.4 OS: Linux
Roadmaps: 2.4.0    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 45 + 1 = ?

 
 [2008-04-13 21:29 UTC] sharedlog (Dmitri Snytkine)
Description: ------------ setLabelAttributes does not have any affect when using toHtml() instead of display() This is because toHtml() method does not reset the value of _status variable. I think this is a fix for the bug: $this->_status = 'show'; should be set at the top of the toHtml method and not in the display() method

Comments

 [2008-04-17 13:59 UTC] doconnor (Daniel O'Connor)
Dmitri, can you provide a short script to demonstrate the problem, and expected output vs actual? That way when we fix the problem it'll stay fixed, as we'll have a test for it.
 [2008-04-18 21:36 UTC] farell (Laurent Laville)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. Answer to Daniel: It's a bit difficult to provide a test script that demonstrate a visual effect. A text label does not correctly appears in examples/template/itxstatic.php Answer to Dmitri: Finally I've decided to choose another solution : add a new status "run" to avoid to change the behaviour of toHtml().