Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.13.1

Bug #12933 levels test failed on x86_64
Submitted: 2008-01-20 07:12 UTC
From: remicollet Assigned: jon
Status: Closed Package: Log (version 1.9.16)
PHP Version: 5.2.5 OS: Linux (Fedora)
Roadmaps: 1.10.0    
Subscription  


 [2008-01-20 07:12 UTC] remicollet (Remi Collet)
Description: ------------ Seems to be an issue with 32/64 bits integer used by php. It's a regression since all tests succed on 1.9.14 Regards Test script: --------------- pear run-tests -p Log Expected result: ---------------- 14 PASSED TESTS 2 SKIPPED TESTS Actual result: -------------- 13 PASSED TESTS 2 SKIPPED TESTS 1 FAILED TESTS: /usr/share/pear/test/Log/tests/levels.phpt levels.diff : 001- Mask: -1 001+ Mask: 4294967295 021- Mask: 2147483647 021+ Mask: -9223372032559808513 041- Mask: -16 041+ Mask: 4294967280

Comments

 [2008-01-20 07:27 UTC] remicollet (Remi Collet)
As 'Priority' (individual bit) are ok, i think it's only a mask display problem. Attached patch give same result on i386 and x86_64.
 [2008-01-20 21:33 UTC] jon (Jon Parise)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.