Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.5.0b5

Request #12732 Add OPTIMIZE/VACUUM TABLE abstraction
Submitted: 2007-12-19 19:38 UTC
From: quipo Assigned: quipo
Status: Closed Package: MDB2 (version 2.5.0a2)
PHP Version: 5.2.5 OS: irrilevant
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 43 - 16 = ?

 
 [2007-12-19 19:38 UTC] quipo (Lorenzo Alberton)
Description: ------------ Requested by Till: add OPTIMIZE/VACUUM TABLE abstraction

Comments

 [2008-01-15 02:00 UTC] till (Till Klampaeckel)
I did some quick research - I think it's OPTIMIZE in MySQL, VACUUM in PgSQL, MSSQL and SQLite.Oracle doesn't need those things (it's "superior" by design here). I couldn't figure out how DB2, Informix, etc. handle this. Btw, I'd also like to see the same for TRUNCATE, etc. - new feature request?
 [2008-01-15 07:24 UTC] quipo (Lorenzo Alberton)
> I did some quick research - I think it's OPTIMIZE > in MySQL, VACUUM in PgSQL, MSSQL and SQLite. > Oracle doesn't need those things I've already written a draft in my dev setup, but it's not so straightforward. I still have to think about how VACUUM is run (FULL? With timeout?), how/if to call ANALYZE afterwards, in a way that is consistent for all drivers. I'll probably add an $options parameter to customize the behaviour. > Btw, I'd also like to see the same for TRUNCATE, > etc. - new feature request? truncateTable() is already implemented in CVS. See request #12731.
 [2008-02-12 19:50 UTC] till (Till Klampaeckel)
What do you mean - FULL or with timeout? (Sorry, I wasn't subscribed.)
 [2008-02-12 23:12 UTC] quipo (Lorenzo Alberton)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. -- Till, those are SQL Server and PostgreSQL VACUUM options