Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.31.0

Bug #10038 Home page license differs from source
Submitted: 2007-02-06 18:35 UTC
From: timj at php dot net Assigned: cellog
Status: Closed Package: pearweb
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2007-02-06 18:35 UTC] timj at php dot net (Tim Jackson)
Description: ------------ http://pear.php.net/package/PEAR says that the package is licensed under the "PHP License" with a link to http://www.php.net/license/2_02.txt . However, all the source files refer to: http://www.php.net/license/3_0.txt PHP License 3.0 Now, investigating more in CVS: package-PEAR.xml contains just this: <license>PHP License</license> package2.xml has the slight variation: <license uri="http://www.php.net/license">PHP License</license> so I don't know if the web frontend is (incorrectly, IMHO) adding a default link to http://www.php.net/license/2_02.txt when <license> is specified without a URL. However I'm not sure whether the frontend is using package2.xml or package-PEAR.xml as its source metadata. The following change to the <license> tags in both package2.xml and package-PEAR.xml should clarify things: <license uri="http://www.php.net/license/3_0.txt">PHP License 3.0</license> I will check it in unless anyone objects.

Comments

 [2007-02-06 18:37 UTC] cellog (Greg Beaver)
this is caused by the license grokking in pearweb
 [2007-02-06 18:41 UTC] timj at php dot net (Tim Jackson)
Thanks Greg. Do you not think that it would be a good idea to synchronise/clarify the source XML files too? This stuff is particularly important to downstream distros wanting clear licensing terms.
 [2007-02-06 18:45 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. The php.net/license page has a link to the latest PHP license, which is what we mean by "PHP License" # P.S. I'm so sick of this license BS. The dang thing is free, why can't people just let it sit?