Vote Details for "MDB2_TableBrowser" by avb

» Details
  • Voter: Alexey Borzov 
  • Vote: -1 (not conditional)
  • Reviews: Deep source review
» Comment
The package depends on MDB2 which is not a E_STRICT-compatible package, so it is against RFC 419 to propose it. It is also not a subpackage of MDB2, so does not qualify for an exception.

Also while the package tries to use a DB abstraction layer, it still has MySQL-specific syntax, i.e. "INSERT ... SET foo = bar".

I suggest reworking the proposal and creating MySQL_TableBrowser instead which will depend only on one of the available MySQL PHP extensions and be E_STRICT-compatible.