I suggest you use PEAR::loadExtension() method instead of @dl() calls.
The constant names should follow the name of the package define('SYSTEM_WINDRIVE', ...)
getGetName() and setGetName() are odd names, why not using getReadNames() and setReadNames().
You may also make your $bGetName, $objAPI and $objFFI private members of the class, and rename them $_readNames, $_objAPI and $_objFFI
I would also suggest to rename $arTypeTitles to $typeTitle. AFAIK we don't prefix variable names by their abbreviated types. BTW, you may want to use the constants you declare above as index of that array.
Also, there may be confusion about adding the trailing backslash to the drive's name. "C:" would be the drive and "\" the name of the root folder on that drive.
Also, make sure you use the new docblock header file.
Also for docblock there is only one space between the * and the text following it. I don't know if the phpDocumentor would choke on that.
Add the @access doc tag information for members and methods.
Just out of curiosity: has this proposal not already been voted for last year? See [url=http://pear.php.net/pepr/pepr-proposal-show.php?id=177]System_WinDrives[/url]. Doing a cursory code review, it seems that you have not changed anything since the first proposal.
Please be so kind to adhere to PEAR's Coding Style as much as possible - see e.g. the page level doc block.