Comments for "Math_Finance"

» Submit Your Comment
Comments are only accepted during the "Proposal" phase. This proposal is currently in the "Finished" phase.
» Comments
  • Matthew Fonda  [2005-03-28 18:31 UTC]

    I have not looked at the code yet (it would be nice to have .phps), but from the description it sounds like a very useful package.
  • Louis Mullie  [2005-03-28 19:19 UTC]

    Sounds very useful.
    A few little things :
    - You should have constants for payment types (FINANCE_PAY_END = 0, FINANCE_PAY_START = 1 or the like)
    - Same thing for the "Type of day count basis"
    - Class "FunctionParameters" should be named "Math_Finance_FunctionParameters"
    - The Newtonraphson.php file should only be included when needed.
    - Your docblocks should have the @static tag to show that all the methods are static.

    - Also, I'm not sure if you should follow either the PEAR standard for the names or the excel API names. I think you could keep the names as they are.

    Appart from those few issues, this is a very nice class and it'd be a great addition to PEAR.
  • Jesus M. Castagnetto  [2005-03-28 20:46 UTC]

    Overall I like the code (mind you that I've gone over it quickly).

    There are some fixable code issues mentioned by others, and I'd like to add that you might have the singleton class in separate file. As you expand the code, it might make it simpler to add things if you have a class per file.

    Apart from these minor things, the package looks good.

    BTW, if you want to, check out a kludgy package I made some time ago (and that I've ex professo put on my site today), which computes statistical index numbers common in finance, etc.

    The URL for that package is: