Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #8773 PDF Convertor fails due to being unable to find fonts
Submitted: 2006-09-23 10:54 UTC Modified: 2006-10-22 13:54 UTC
From: phpdoc at ryanwilliams dot org Assigned: cellog
Status: Closed Package: PhpDocumentor (version 1.3.0)
PHP Version: 5.1.6 OS: Linux / FreeBSD
Roadmaps: (Not assigned)    
Subscription  


 [2006-09-23 10:54 UTC] phpdoc at ryanwilliams dot org (Ryan Williams)
Description: ------------ PDF:default:default causes a lot of undefined index errors when trying to output a PDF. The resulting file is screwed up. The cause is due to the class.pdf.php file looking in a relative directory for the fonts "./templates/fonts". The full path being: /usr/local/share/pear/PhpDocumentor/phpDocumentor/Converters/ PDF/default/templates/fonts/ This fails because pear has placed the fonts in the following directory /usr/local/share/pear/data/PhpDocumentor/phpDocumentor/ Converters/PDF/default/templates/fonts/ A simple symlink to the templates directory fixes the issue. Test script: --------------- Just output any documentation as PDF:default:default Expected result: ---------------- A working PDF file Actual result: -------------- Screwed up PDF as the convertor is unable to work out the height of the fonts and prints every line of text directly on top of the next

Comments

 [2006-10-22 13:54 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.