Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #7577 Notice error for undefined _pv_function_param property
Submitted: 2006-05-08 04:09 UTC Modified: 2006-08-16 20:31 UTC
From: farell Assigned:
Status: Duplicate Package: PhpDocumentor (version 1.3.0RC6)
PHP Version: 4.4.2 OS: Windows XP
Roadmaps: (Not assigned)    
Subscription  


 [2006-05-08 04:09 UTC] farell (Laurent Laville)
Description: ------------ I've just installed PHPDocumentor 1.3.0RC6 and generated API for PEAR_PackageUpdate with the web interface. I got lot of notice errors: all the same (see message below). Solution: declare the missing property $_pv_function_param in phpDocumentorTParser class of file [...]\PhpDocumentor\phpDocumentor\phpDocumentorTParser.inc Expected result: ---------------- no notice error on build process log window. Actual result: -------------- Notice: Undefined property: _pv_function_param in [...]\PhpDocumentor\phpDocumentor\phpDocumentorTParser.inc on line 615

Comments

 [2006-05-17 17:41 UTC] cellog (Greg Beaver)
dupe of Bug #7548
 [2006-06-12 15:53 UTC] farell (Laurent Laville)
Greg, May i ask you to define the property as var $_pv_function_param; into class because it was not done yet into last revision r1.14 of phpDocumentorTParser.inc It will be more cleaner. Laurent
 [2006-06-19 02:20 UTC] douglaswrg7 at yahoo dot com (Douglas Wright)
Just a note that PHP-4.4.1 will still show this error even after adding the declaration. This is due to a bug found in PHP: http://www.zend.com/zend/week/week75.php. Works fine after edit using PHP-5.1.2.
 [2006-08-15 18:46 UTC] klundgren at highcountrygardens dot com (Karen Lundgren)
I got this message to go away by adding the following line just above where the error occurred: if (!isset($this->_pv_function_param)) { $this->_pv_function_param = ''; }
 [2006-08-16 20:31 UTC] cellog (Greg Beaver)
Dupe of #7548, please use that bug for comments
 [2006-10-11 14:54 UTC] euclides dot rodriguez at gmail dot com (Euclides Rodriguez)
I have configured PhpDocumentor 1.3.0RC6 and PHP 4.4.1 and only add the variable in the class phpDocumentorTParser and it work well.