Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #7328 Tutorial-Manual appears larger than browser window
Submitted: 2006-04-06 13:01 UTC Modified: 2006-10-22 23:12 UTC
From: quincunx55555 at yahoo dot com Assigned:
Status: Bogus Package: PhpDocumentor (version 1.3.0RC5)
PHP Version: 5.1.2 OS: Fedora Core 5
Roadmaps: (Not assigned)    
Subscription  


 [2006-04-06 13:01 UTC] quincunx55555 at yahoo dot com (Troy)
Description: ------------ While viewing the following web pages using Firefox 1.5.0.1 in a maximized window at 1152x864, side-scrolling is necessary to read the text. According to Joshua Eichorn, this appears to be from a table width set to 100%. The URL's in question are in the "Test script" section of this entry. From what I can tell the rest of the pages are okay, but haven't viewed them with lower resolution than the one mentioned above. Test script: --------------- http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_phpDocumentor.howto.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_elements.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_tags.author.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_tags.global.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_tags.license.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_tags.package.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_tags.param.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_tags.see.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_tags.staticvar.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_tags.subpackage.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_tags.inlinelink.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_tags.inlinesource.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_tags.inlinetutorial.pkg.html http://manual.phpdoc.org/HTMLSmartyConverter/HandS/Converters/tutorial_Converters.pkg.html Expected result: ---------------- I would expect to read the tutorial and manual without side-scrolling. Actual result: -------------- To read most paragraphs, and click the "Next" link, scrolling to the right is required. Sometimes viewing an entire paragraph is not possible.

Comments

 [2006-10-05 16:25 UTC] ashnazg at users dot sourceforge dot net (Chuck Burgess)
Using stable v1.3.0, I see this horizontal scroll behavior in the HTML converters. I'm on WinXP and see the behavior on IEv6 as well as Firefox 2.0. However, I think the platform is irrelevant (see below). It looks to me like all the literal " " spacing characters being included in the example code blocks of the docs is the reason for the page width not shrinking. I can shrink the page width ok until the right edge meets one of these code block areas of the doc. When I manually remove all the "&nbps;" characters from that text, the page width would then adjust smaller and no longer show a horizontal scroll bar. Try it yourself by removing them from the lines in the 'define("almost"' and 'define("ahhhh"' lines in the "Documentable PHP Elements" page (http://manual.phpdoc.org/HTMLSmartyConverter/HandS/phpDocumentor/tutorial_elements.pkg.html). I have to assume that PhpDocumentor is EXPLICITLY putting those " " characters in there specifically to retain the exact line spacing that exists in the source code file it is documenting. This assumption seems true when you look directly at the elements.pkg file in the tutorials/phpDocumentor/examples directory of the CVS source code, where these literal HTML space entities are NOT put there by the comment author. So, this appears to me to be explicit PhpDoc behavior which SHOULD remain intact (i.e. not a bug). I would say that it is the responsibility of the comment author creating the code that is to be phpDoc'd to ensure his comment lines themselves are relatively narrow, if he wants to concern himself with how wide his readers' browser windows will typically be. I'd recommend this be closed as CODE WORKING PROPERLY. Granted, it was an interesting experience for me to troubleshoot ;)
 [2006-10-22 23:12 UTC] cellog (Greg Beaver)
as the last comment observes, this is expected behavior.