Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.3.0

Bug #6905 _getCache() function return false
Submitted: 2006-02-23 08:45 UTC Modified: 2006-05-30 16:37 UTC
From: fvailleau at sqli dot com Assigned: avb
Status: Closed Package: HTML_Template_Sigma (version 1.1.4)
PHP Version: 4.3.4 OS: Windows, Linux
Roadmaps: (Not assigned)    
Subscription  


 [2006-02-23 08:45 UTC] fvailleau at sqli dot com (Fred VAILLEAU)
Description: ------------ In the _getCache() method, you are using the unserialize function which had problem with the \r character. I placed the following ligne before the unserialize call and it works fine : $content = str_replace("\r", "", $content); Here is a post explain the bug : http://fr3.php.net/manual/fr/function.unserialize.php#45347

Comments

 [2006-02-26 13:15 UTC] avb
Looks like the problem is not in unserialize, but in not using the 'b' modifier for fopen(). Will fix this soon.
 [2006-05-30 16:37 UTC] avb (Alexey Borzov)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.