Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #18871 Class tree wont shows internal PHP interfaces
Submitted: 2011-09-25 08:34 UTC Modified: 2011-10-14 04:21 UTC
From: drunkenstranger Assigned: ashnazg
Status: Closed Package: PhpDocumentor (version SVN)
PHP Version: 5.2.12 OS: Windows XP
Roadmaps: 1.4.4    
Subscription  


 [2011-09-25 08:34 UTC] drunkenstranger (Drunken Stranger)
Description: ------------ Class tree wont shows internal PHP interfaces. Test script: --------------- <?php /** Test file for MyPackage2 class tree * @package MyPackage */ /** @package MyPackage */ class MyClass implements Countable {} /** @package MyPackage */ class MyClass2 extends MyClass {} ?> Expected result: ---------------- Root class MyClass MyClass (implements Countable) MyClass2 Actual result: -------------- Root class MyClass MyClass (implements ) MyClass2

Comments

 [2011-09-25 09:03 UTC] drunkenstranger (Drunken Stranger)
 [2011-10-07 20:11 UTC] ashnazg (Chuck Burgess)
-Roadmap Versions: +Roadmap Versions: 1.4.4
 [2011-10-12 20:32 UTC] ashnazg (Chuck Burgess)
-Status: Open +Status: Verified -Assigned To: +Assigned To: ashnazg
Verified this behavior using v1.4.3 against PHP 5.3.8 and 5.2.17. Refined the test case to show both the bug behavior and correct behavior. Also verified that the issue is irrelevant when using PHP 4.4.9. Further, I found that *any* kind of interface is not visible in this scenario when using the HTML:Smarty:HandS converter. The HTML:frames:default converter shows a user-defined interface properly, while failing to show an internal interface (as reported by this bug).
 [2011-10-14 04:21 UTC] ashnazg (Chuck Burgess)
-Status: Verified +Status: Closed
Followed the concept of the provided patch to pull interface handling outside of the child class handling logic. Tests good on PHP 5.3.8, 5.2.17, and 4.4.9 to solve the interface listing issues in the class list view. Committed to SVN.