Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #18870 Class tree wont shows implemented interfaces if class has no childs
Submitted: 2011-09-25 08:31 UTC Modified: 2011-10-14 04:17 UTC
From: drunkenstranger Assigned: ashnazg
Status: Closed Package: PhpDocumentor (version SVN)
PHP Version: 5.2.12 OS: Windows XP
Roadmaps: 1.4.4    
Subscription  


 [2011-09-25 08:31 UTC] drunkenstranger (Drunken Stranger)
Description: ------------ Class tree wont shows implemented interfaces if class has no childs. Test script: --------------- <?php /** Test file for MyPackage2 class tree * @package MyPackage */ /** @package MyPackage */ interface MyInterface {} /** @package MyPackage */ class MyClass implements MyInterface {} ?> Expected result: ---------------- Root interface MyInterface MyInterface Root class MyClass MyClass (implements MyInterface) Actual result: -------------- Root interface MyInterface MyInterface Root class MyClass MyClass

Comments

 [2011-09-25 09:03 UTC] drunkenstranger (Drunken Stranger)
 [2011-10-07 20:11 UTC] ashnazg (Chuck Burgess)
-Roadmap Versions: +Roadmap Versions: 1.4.4
 [2011-10-12 19:54 UTC] ashnazg (Chuck Burgess)
-Status: Open +Status: Verified -Assigned To: +Assigned To: ashnazg
Verified this behavior using v1.4.3 against PHP 5.3.8 and 5.2.17. Refined the test case to show both the bug behavior and correct behavior. Also verified that the issue is irrelevant when using PHP 4.4.9.
 [2011-10-14 04:17 UTC] ashnazg (Chuck Burgess)
-Status: Verified +Status: Closed
Followed the concept of the provided patch to pull interface handling outside of the child class handling logic. Tests good on PHP 5.3.8, 5.2.17, and 4.4.9 to solve the interface listing issues in the class list view. Committed to SVN.